Knowledgebase
Completely remove DesignBuilder v4 from a computer
Posted by Andy Tindale on 14-Mar-19 10:42 AM

PLEASE NOTE: ONLY TO BE USED FOR DESIGNBUILDER VERSION 4 SOFTWARE

Please note that by following these instructions you will also delete your Component, Template and Weather data libraries. To avoid this you should export your libraries before removing DesignBuilder using the File > Export > Library data menu command from the opening screen. You should also make copies of any weather files you wish to keep.

Under certain circumstances it can be useful to completely remove all traces of previous DesignBuilder installations from a computer in order to start from scratch. To do this follow the instructions below. 

You will need Administrator privileges on the machine to carry put this procedure.

1. Start an DesignBuilder session and navigate to Help>License and on the License Manager dialog press the "Reset" button to release any licenses.

2. If you haven't done so already, set your Folder Options so you can see hidden files, folders and drives:

          On Windows XP:
         
              From an Explorer window:
             
                  i) Tools -> Folder Options ...
                 
                  ii) Click the view tab
                 
                  iii) Select "Show hidden files, folder and drives"
                 
                  iv) Click Ok.
         
          On Windows Vista, Windows 7 and Windows 8:
         
              From an Explorer window:
             
                  i) Organize -> Folder and Search Options
                 
                  ii) Click the view tab
                 
                  iii) Select "Show hidden files, folder and drives"
                 
                  iv) Click Ok.

         On Windows 10:
         
              From an Explorer window:
             
                  i) Click the View tab
                 
                  ii) Select "Hidden items"
                 
                         
3. Stop the simulation manager:

          On Windows XP:

              i) Open an explorer window and navigate to C:\Documents and Settings\<your username>\Local Settings\Application Data\DesignBuilder\JobServer
              
              ii) double click deleteservice.bat

          On Windows Vista, Windows 7, Windows 8 and Windows 10:

              i) Open an explorer window and navigate to C:\Users\<your username>\AppData\Local\DesignBuilder\JobServer
              
              ii) right click deleteservice.bat - select "Run as administrator"

Note:

If you experience problems with stopping the simulation manager then you may also need to navigate to Task Manager and manually end the DBJobServer.exe process.
 
4. Uninstall DesignBuilder using the "Program and Features" program accessed from the Windows Control Panel.
       
5. Delete the following folders, if they exist:

          On Windows XP:

              C:\Program Files\DesignBuilder             
              C:\Documents and Settings\All Users\Application Data\DesignBuilder

              Delete folders and files at C:\Documents and Settings\<your username>\Local Settings\Application Data\DesignBuilder EXCEPT those indicated on step 6 below:

          On Windows Vista, Windows 7, Windows 8 and Windows 10:

              C:\Program Files\DesignBuilder
              C:\Program Files (x86)\DesignBuilder
              C:\Users\<your username>\AppData\Local\DesignBuilder\
              C:\Users\<your username>\AppData\Local\VirtualStore\Program Files\DesignBuilder
              C:\Users\<your username>\AppData\Local\VirtualStore\Program Files (x86)\DesignBuilder
              C:\Users\<your username>\AppData\Local\VirtualStore\ProgramData\DesignBuilder

              Delete folders and files at the above locations EXCEPT those indicated on step 6 below:

6. Do NOT delete the following folders and files (if they exist):

          On Windows XP:

             C:\Documents and Settings\<your username>\Local Settings\Application Data\DesignBuilder\Licenses

             C:\Documents and Settings\<your username>\Local Settings\Application Data\DesignBuilder\DBSystemSettings.txt

             C:\Documents and Settings\<your username>\Local Settings\Application Data\DesignBuilder\Reprise

          On Windows Vista, Windows 7, Windows 8 and Windows 10:

             C:\ProgramData\DesignBuilder\Licenses

             C:\ProgramData\DesignBuilder\DBSystemSettings.txt

             C:\ProgramData\Reprise

See also: